# compose

Zach Klippenstein (he/him) [MOD]

04/30/2020, 5:22 AM
I’m using kotlin 1.3.72, and after updating to compose dev10 I got warnings about
Runtime JAR files in the classpath have the version 1.3, which is older than the API version 1.4. Consider using the runtime of version 1.4
. These go away if I add the
apiVersion = "1.3"
configuration for my
tasks, and the code runs fine. Are these warnings expected? Should we be using Kotlin 1.4-M1 to use Compose now?
The full set of messages was:

Leland Richardson [G]

04/30/2020, 6:17 AM
Yeah, seems like some others are getting this too. I'm not sure the right answer and will report back when I do. The actual compiler we are using is a snapshot that is neither 1.3 or 1.4 really and the code written to emit these warnings assumes that that isn't a possible scenario :)
👍 1
🙂 1

Zach Klippenstein (he/him) [MOD]

04/30/2020, 6:39 AM