I'm struggling with a "Hello world" example with k...
# kotless
I'm struggling with a "Hello world" example with kotless 0.1.7-beta-5, kotlin 1.4.21 - I can run locally, but the
tasks fail with the error:
Copy code
Execution failed for task ':initialize'.
> Command failed: 'D:\Development\Experiments\Kotless\KotlessTestBeta\build\kotless-bin\terraform  '

* Try:
Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Exception is:
org.gradle.api.tasks.TaskExecutionException: Execution failed for task ':initialize'.
	at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.lambda$executeIfValid$1(ExecuteActionsTaskExecuter.java:188)
	at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter$$Lambda$481/0x0000000000000000.accept(Unknown Source)
In my build folder there is no folder called
I tried the same code in a Linux VM, and although it failed at the same point, it failed for a sensible reason - I haven't set up AWS credentials in my VM. In the Linux VM,
is downloaded to the build\kotless-bin\ folder.
Not tested in Windows?
Currently trying to build 0.2.0 locally. This version at least correctly downloaded the terraform binary. To run the example ktor app from 0.2.0 I had to disable the references to graalVM.
... but my own project is not downloading terraform.
I'm beginning to think kotless breaks authentication on Ktor...
It’s pretty strange) I’ll check it
I've got it working, but the download_terraform task seems very fragile on Windows. I don't ever risk running
gradlew clean
in case I can't get the terraform download to work again.
I've solved my authentication problem, though I'm not sure if the ktor documentation is wrong for oauth, or if kotless does something strange to the authentication routes.