Brady Aiello

    Brady Aiello

    1 year ago
    Just upgraded to Arctic Fox, changed my
    JAVA_HOME
    to 11, made sure AS is using 11 as the runtime, and tried changing it gradle.properties as well, and I'm still getting this:
    > Failed to apply plugin 'com.android.internal.application'.
    > Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8.
    You can try some of the following options:
    - changing the IDE settings.
    - changing the JAVA_HOME environment variable.
    - changing `org.gradle.java.home` in `gradle.properties`.
    I can build just fine from the terminal. Anyone solve this issue?
    Solved my issue. I couldn't find an option to configure the JDK for Gradle anymore. So, I removed JDK 8 from my machine altogether, opened AS again, it told me my Gradle configuration was invalid (pointing to JDK 8 which has been removed), and I set it to my
    JAVA_HOME
    location. 🙂