06/04/2021, 2:39 PM
I'm not sure if this is fixable but I've found that there's cursor lag when using an enabled G-Sync display with the DirectX renderer (in Windows) as I imagine that the cursor is tied to the fps in this case. Turning G-sync off (which isn't ideal as I have to do this globally) or using the OpenGL setting fixes this.

Igor Demin

06/04/2021, 2:59 PM
What you mean by "cursor lag"? It become slow when you start Compose application. Or is it always behind when you drag something? Is cursor a native cursor or your own?


06/04/2021, 3:15 PM
I mean cursor lag as in the displayed fps of the cursor, so a laggy cursor would display changes less than a normal cursor. It lags I imagine whenever the fps of the application drops. This usually happens right after a button is clicked which drops the cursor fps to around 2-5 fps. And I meant cursor as in the normal windows cursor.
Most of the time it's at a normal fps though


06/04/2021, 4:11 PM
Gsync is pesky. What version of compose desktop are you using?


06/04/2021, 4:20 PM
The current one (0.4.0), and it's been like this since directx was introduced
It seems like this is similar to an issue with the new Microsoft terminal with their hardware acceleration: It seems the only solution there is to just to use the software renderer or disable gsync as well
I have managed to figure out how to disable it in the application level with nvidia inspector so it's not too much of an issue now

Albert Chang

06/04/2021, 5:28 PM
G-sync shouldn't enabled for windowed mode in the first place as it will likely cause many issues with little return.


06/04/2021, 5:31 PM
It was already set to fullscreen only, for some reason it only turns off when I set it completely off