I am having issue with naming in general. It seems...
# compose-desktop
y
I am having issue with naming in general. It seems that from what I can read, functions are named XXX and "models" are named XXXViewModel which for me seems very non intuitive. Especially since function start with a capital letter. For example if I have a Song "concept", then when I see Song in my code, it looks like it should be the object "song" not the function that renders a SongViewModel... Maybe it's just me and I know that I can do whatever I want in my code but was wondering if others felt that way and what other conventions they have been using...
j
When I see a Composable named
Song
, that doesn't tell me anything about what it is going to look like. Is this a
SongSearchResult
or a
SongPlayer
or a
SongCard
etc. I typically give my data types the good names, and the composables get names that give me a better sense of how that song is going to be rendered.
1
Especially as your app grows, you will generally render the same data type in several different ways, and they will need to be disambiguated anyway.