11/11/2020, 9:37 PM
To anyone trying out jetpack compose, I’m having significantly less weird IDE behavior when I use Android Studio instead of IntelliJ. I recommend using Android Studio to play around with things.
🤔 3


11/11/2020, 10:20 PM
Can you elaborate on what "weird IDE behavior"? Perhaps file/link some bugs?


11/12/2020, 12:28 AM
What kinda behavior?


11/12/2020, 1:23 AM
I had a similar experience. I don't remember exactly what was wrong, but in Intellij everything in my Gradle files were red


11/12/2020, 2:35 AM
After thinking about it more, I’ve experienced issues like this before when writing Android projects in IntelliJ mixed with JVM projects. 1. I have to gradle sync multiple times before the alert / notification that you need to sync goes away. It’s almost like the first or second sync doesn’t always take, or there is a race condition, and I have to get lucky. 2. My Deps.kt inside my buildSrc started complaining for no reason that it couldn’t find
function. Of course it compiles fine. 3. I had a multiplatform library module with a class exposed in the JVM layer, and I couldn’t access it from another module for desktop use. It was a jvm module (to compile for desktop), but it wouldn’t resolve, so I try moving it to a multiplatform module. Same issue. I invalidate cache and restart. Same issue. I move to Android Studio, and everything is hunky dory. There were probably some other strange idiosyncrasies also. These are what I remember though. 4. This is super minor, but I created a gradle run configuration for my
./gradlew :desktop:run
equivalent, and intellij makes it look like it’s going to start my android emulator every time I click run (even though it doesn’t). It’s super annoying. Android Studio displays this much more clearly
5. This one was pretty annoying - When I would run the gradle command from the IDE configuration, I had to exit the process manually. Running again wouldn’t exit the process (even though I told it to) , and I’d end up with the app running multiple times. Android Studio works fine. I can exit the process with the stop button in the IDE, and if I run it while it’s already running, it exits the current process.

Sebastian Sellmair [JB]

11/12/2020, 7:34 AM
Thank you for your feedback! Which versions of Android Studio vs IntelliJ are you comparing?


11/12/2020, 11:56 PM
I see 1,2,3 problems on Intellij 2020.2.3, and not on AS 4.2canary16. If I am not mistaken AS had some improvements on gradle kts support between these versions. Also it's very concerning that new Intellij 2020.3 seems to be released without incorporating support for AGP 4.1. Which has many fixes (like
newer version). At the same time Kotlin 1.4.20 is being released with deprecated
plugin which should be replaced by
. 😄 This seems like dependency hell. Everyone fixes their own project issues, release new version, but don't include other's project fixes. While end user needs all fixes to work normally. So many parties coupled. No wonder why Apply has zero interest to working with anyone.
☝️ 1

Sebastian Sellmair [JB]

11/13/2020, 9:23 AM
I can totally feel you on this one! Support for AGP 4.1 is on the way right now 👀. Of course, the whole story is really complicated. Philosophically, I would love to discuss the analogy to Apple here (if we would have time to go into details). Very interesting topic! However, dependency hell is still not a foreseeable danger IMO. Deprecation does not mean, that it will be removed tomorrow 😛
👍 1
Last statement: If everyone would work like Apple, our life as engineers would be pretty boring. I think cooperations are not just fun, but often lead to very cool things! Especially JetBrains + Google had a looooot of good implications for Android aaas well as IntelliJ aaaas well as Kotlin


11/13/2020, 6:25 PM
I’m using IntelliJ Ultimate 2020.2.3 and AS 4.1