Thread
#multiplatform
    alexandrepiveteau

    alexandrepiveteau

    1 year ago
    Hi ! Gradle newbie question here. I’ve got a KMM project which uses
    kotlinx.serialization
    , and targets both Kotlin/JS and Kotlin/JVM (with a Compose for Desktop client). Compose for Desktop requires using Kotlin 1.5.10, but there’s a bugfix in
    kotlinx.serialization
    for Kotlin 1.5.20 which I need for my Kotlin/JS target. Would there a way for me to fix my Gradle project and satisfy these two requirements ? (code in 🧵)
    I’ve also tried applying the Kotlin plugin in each module
    build.gradle.kts
    individually, but got the following warning :
    The Kotlin Gradle plugin was loaded multiple times in different subprojects, which is not supported and may break the build.
    k

    kevindmoore

    1 year ago
    Can you use 1.5.20?
    alexandrepiveteau

    alexandrepiveteau

    1 year ago
    Not with Compose for Desktop apparently.
    g

    Guilherme Delgado

    1 year ago
    it’s not possible to use Compose 1.0.0-rc01 with 1.5.20. We have to wait that compose uses 1.5.20