Thread
#multiplatform
    a

    ahmedre

    2 years ago
    Hi, was curious if anyone had any luck building projects with Xcode 12 beta - I have a project with Cocopods integration that builds fine under Xcode 11.x, but on Xcode 12 beta, the same project fails with:
    REPO_ROOT="$PODS_TARGET_SRCROOT"
    
                    "$REPO_ROOT/../gradlew" -p "$REPO_ROOT" :common:syncFramework                     -Pkotlin.native.cocoapods.target=$KOTLIN_TARGET                     -Pkotlin.native.cocoapods.configuration=$CONFIGURATION                     -Pkotlin.native.cocoapods.cflags="$OTHER_CFLAGS"                     -Pkotlin.native.cocoapods.paths.headers="$HEADER_SEARCH_PATHS"                     -Pkotlin.native.cocoapods.paths.frameworks="$FRAMEWORK_SEARCH_PATHS"
    
    Error: Could not find or load main class org.gradle.wrapper.GradleWrapperMain
    
    Caused by: java.lang.ClassNotFoundException: org.gradle.wrapper.GradleWrapperMain
    Tried manually replacing
    REPO_ROOT
    with the correct folder there but didn’t help. Don’t think it’s cocoapods related because before cocopoads, I had the manual connection way first and that was also failing with the same issue only on Xcode 12 beta.
    also seeing this happen with John’s BikeShare app - builds fine for me in Xcode 11 but on Xcode 12, fails with the same issue.
    John O'Reilly

    John O'Reilly

    2 years ago
    Which XCode 12 beta are you using? I just tested BikeShare iOS app with XCode 12 beta 3 and it built/ran ok (and in fact the BikeShare macOS app depends on using XCode 12 as it uses SwiftUI 2 functionality)
    (though, for iOS app, am seeing SwiftUI
    TabView
    seemingly not behaving as expected when using XCode 12 beta)
    a

    ahmedre

    2 years ago
    12 beta 3 also 🤔
    yeah not sure why - doesn’t make much sense
    tried going back to not using Cocoapods (just to easier debug what’s happening) and printed out things like the classpath gradle wrapper is passing to gradle, etc, and everything looks fine. guessing its Big Sur related then ¯_(ツ)_/¯