spierce7

    spierce7

    2 years ago
    I keep seeing an error on 1.3.70 when syncing my multiplatform project, that errors our the sync:
    New Gradle Sync is not supported due to containing Kotlin modules
    That’s all the information provided in the IDE, and I can’t repro via command line. Anyone have any idea/
    kpgalligan

    kpgalligan

    2 years ago
    What version of the ide?
    spierce7

    spierce7

    2 years ago
    IntelliJ IDEA 2019.3.3 (Ultimate Edition)
    Build #IU-193.6494.35, built on February 10, 2020
    Licensed to Rally Health / Scott Pierce
    You have a perpetual fallback license for this version
    Subscription is active until March 1, 2021
    Runtime version: 11.0.5+10-b520.38 x86_64
    VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
    macOS 10.15.3
    GC: ParNew, ConcurrentMarkSweep
    Memory: 6060M
    Cores: 12
    Registry: 
    Non-Bundled Plugins: Dart, Key Promoter X, com.intellij.nativeDebug, com.jetbrains.php, com.oliverlockwood.plugins.jenkinsfile, org.jetbrains.kotlin, com.squareup.sqldelight, io.flutter, org.jetbrains.idea.grammar, org.jetbrains.plugins.hocon
    I’m only on Gradle 6.2. Going to try moving to 6.2.2
    still seeing it after moving to Gradle 6.2.2
    kpgalligan

    kpgalligan

    2 years ago
    I’ve seen it but it hasn’t stopped things from working, so not sure what to do about it specifically. We’re not moving to gradle 6 yet
    spierce7

    spierce7

    2 years ago
    You guys see it in Gradle 5?
    kpgalligan

    kpgalligan

    2 years ago
    I would move to gradle 6 when moving to 1.3.70 and intellij 2020.1, but that’s not official or anything
    spierce7

    spierce7

    2 years ago
    It appears I can resolve the iOS code now
    I’m on 1.3.70
    kpgalligan

    kpgalligan

    2 years ago
    I’ve seen it. It also wasn’t a problem, so I don’t have a strict recollection of when and what circumstances
    spierce7

    spierce7

    2 years ago
    I see it every other sync it appears.
    and it also makes that stupid blue bar at the top telling you to sync gradle never go away. Have you guys created a ticket for this?
    kpgalligan

    kpgalligan

    2 years ago
    I tend to focus less on ide errors as they were far more frequent earlier on. Just noise at this point.
    No
    spierce7

    spierce7

    2 years ago
    gonna file one I suppose
    kpgalligan

    kpgalligan

    2 years ago
    I’m also on 2020 for anything in 1.3.70 range
    spierce7

    spierce7

    2 years ago
    I’ll try moving to 2020