Is it possible to change the name of wrapper objec...
# multiplatform
y
Is it possible to change the name of wrapper object of top level functions? If I define
fun calculate():Int
in
Util.kt
, We have to call it like
UtilKt.calculate()
in Swift but I want
Util.calculate()
. In jvm we have
@JvmName
, but in native I can't find the equivalent
s
There appears to be
CName
for C/C++, not sure if that also applies to Obj-C
y
Thanks, but
CName
seems to be not applicable to file 😞
and
SymbolName
is also not applicable
s
It is not possible yet.
y
got it, thanks!