r

    robstoll

    4 years ago
    I am struggling with intellij, I can build my project with gradle but suddenly intellij throws the following error for my common module
    Error:(3, 1) Kotlin: The feature "multi platform projects" is experimental and should be enabled explicitly
    Anybody had the same experience and can give me a pointer?
    ilya.gorbunov

    ilya.gorbunov

    4 years ago
    Do you get this error from gradle build? Do you use
    freeCompilerArgs
    compiler task option?
    r

    robstoll

    4 years ago
    gradle works fine (on the console, also in the gradle view). Even rebuild project is green but the above mentioned error pops up in the messages view. Due to this I cannot longer run tests (unless I activate Delegate IDE run/build actions to gradle)
    I just updated to 2017.3.5 and tried it again without the delegate
    i get the error that no SDK is defined for the common module. Yet, that seems to be OK (it is at least also like that when I let IntelliJ create a new multi-platform project)
    forgot to mention, specifying the SDK does not help, I still have the same error as initially described