`!` is a single, slender character that’s easier t...
# codingconventions
s
!
is a single, slender character that’s easier to gloss over than
not
is
g
It’s hard to follow if you have
!
on start of long expression or chain of calls So
not
as part of last call is more natural to read, compare
!something.isNullOrBlank()
=
not something is null or blank
and
something.isNotNullOrBlank()
=
something is not null or blank
not
as postfix also work, but reads not so naturally:
something.isNullOrBlank().not()
=
something is null or blank not
s
for sure, we’re on the same page