<https://github.com/JetBrains/kotlin-web-site/blob...
# codingconventions
m
https://github.com/JetBrains/kotlin-web-site/blob/yole/styleguide/pages/docs/reference/coding-conventions.md#source-file-names I often hear that files with extension functions should be named with "Ext" suffix.
y
files should be named according to their semantic contents, and extension functions should have as narrow scope as possible. the idea of “a file with extension functions” goes actively against both of those rules, so this is not something that we’d want to endorse
m
From my practice, developers are often making extension functions to extract some commonly used patterns. Like displaying toast on the screen. This is why in nearly every Kotlin Android projects I see classes like ViewExt, ContextExt etc.
y
this is also entirely unnecessary; they should just use Anko