# realm


07/06/2022, 11:12 AM
in the docs it says you need android studio to use the kmp library. I use intellij for my multiplatform libs. is there anyway to make it work?


07/06/2022, 5:03 PM
It should work AFAIK if you have Intellij with the Android Support plugin.


07/06/2022, 10:36 PM
I wasn’t able to get it to compile adding the plugin and dependencies.
ok I got it to work. it compiles anyway.
🎉 1
ok so it turns out I misspoke. I didn’t compile I just got the gradle sync to succeed. Once I tried to publish to maven local it failed. I get this error even though I’ve added
Copy code
Could not determine the dependencies of task ':compileKotlinIosArm64'.
> Could not resolve all task dependencies for configuration ':iosArm64CompileKlibraries'.
   > Could not resolve org.jetbrains.kotlinx:kotlinx-coroutines-core:1.6.0-native-mt.
     Required by:
         project :
         project : > io.realm.kotlin:library-sync:1.0.0 > io.realm.kotlin:library-sync-iosarm64:1.0.0
In the documentation it says to add
to the build script of the project level build.gradle file however since I’m not using android studio I don’t have a project level build.gradle file. I’ve tried putting inside the settings.gradle similar to
but it didn’t help. Not sure what else to even look at. Any ideas? Was anyone else able to get it to work from IntelliJ?
The way I got it to sync was to use
Copy code
id("io.realm.kotlin") version "1.0.0"
which is different to the documentation. But yeah seems I need to do something else also.
ok I was able to get it to compile in a new test library. I was also to reproduce this behaviour by adding ktor libraries. It seems ktor conflicts with
Copy code
not sure yet how to resolve that though.
it says to use
but it didn’t work. Not sure how to make ktor use that version.