https://kotlinlang.org logo
#compose-desktop
Title
# compose-desktop
k

Kirill Grouchnikov

01/30/2023, 4:29 PM
image.png
K 19
🦜 19
🎉 5
Looks like it’s now using the correct system font on macOS (SF Pro), which is a very welcome change
o

Oleksandr Karpovich [JB]

01/30/2023, 5:30 PM
JFYI: uploading to mavenCentral is still in progress. And then we’ll update the Change Log
p

Pablichjenkov

01/30/2023, 6:25 PM
Dang, it was quick, no time to test 1.3.0-rc06
o

Oleksandr Karpovich [JB]

01/30/2023, 6:37 PM
The only 1 change in 1.3.0-rc06 is a fix for compose compiler plugin - version 1.4.0-rc03. That fix was for k/js. Other than that it’s the same as 1.3.0-rc05
h

hfhbd

01/30/2023, 10:36 PM
Is it expected to support Kotlin 1.7.20 (with compose 1.3) too?
a

Adam Brown

01/31/2023, 4:55 AM
might as well go Kotlin 1.8.0 at this point I think?
o

Oleksandr Karpovich [JB]

01/31/2023, 6:43 AM
Kotlin 1.7.20 is expected to be supported with Compose 1.3 for desktop. IIRC k/js works too. But it’s known to be NOT supported for k/native. So kotlin 1.8.0 is the choice to have all targets supported.
x

xxfast

02/07/2023, 10:02 PM
does the 1.3.0 (stable) use compose compiler plugin version 1.4.0-rc03?
trying to bump to kotlin 1.8.10 and not sure if this error indicates that, or if this is some other dependency
Copy code
This version (1.4.0-rc03) of the Compose Compiler requires Kotlin version 1.8.0 but you appear to be using Kotlin version 1.8.10 which is not known to be compatible.  Please consult the Compose-Kotlin compatibility map located at <https://developer.android.com/jetpack/androidx/releases/compose-kotlin> to choose a compatible version pair (or `suppressKotlinVersionCompatibilityCheck` but don't say I didn't warn you!).
k

Kirill Grouchnikov

02/07/2023, 10:37 PM
It says right there what you can try to do
x

xxfast

02/07/2023, 10:45 PM
sorry - i should've been clearer. I'm trying to track down where of the Compose Compiler version 1.4.0-rc03 is pulled in from. Having no luck with
./gradlew module:dependencies
- there's an integration issue thats currently impacting me
from what i can see jetbrains.compose 1.3.0 stable release is supposed to use compiler version 1.4 right?
k

Kirill Grouchnikov

02/07/2023, 11:09 PM
Do you have a link to that documented, or is that your expectation?
Don’t take this as 100% guarantee, but https://github.com/JetBrains/compose-jb/blob/master/VERSIONING.md#using-jetpack-compose-compiler doesn’t say that compose-jb 1.3.0 is using compiler 1.4.0. It says that 1.4.0 is compatible with Kotlin 1.8.0 which is what compose-jb 1.3.0 is using, and if you choose to use compiler 1.4.0, then those are the instructions in that section.
o

Oleksandr Karpovich [JB]

02/08/2023, 7:38 AM
1.3.0 uses org.jetbrains.compose.compilercompiler1.4.0 with kotlin 1.8.0 https://github.com/JetBrains/compose-jb/blob/release/1.3.0/gradle-plugins/compose/src/main/kotlin/org/jetbrains/compose/ComposeCompilerCompatability.kt#L10 That "1.4.0-rc03" in the error message has mistakenly sneaked in (I missed that. 1.4.0-rc03 is the same as 1.4.0 commit-wise)
11 Views