https://kotlinlang.org logo
#datascience
Title
# datascience
k

Kane Shih

02/01/2023, 10:55 AM
I can’t use
dataframe
in Jupyter Notebook on Mac(macOS 12.6.3). It’s visible in auto-complete and :help. Details in attached screenshots.
Copy code
❯ jupyter troubleshoot
$PATH:
	/opt/homebrew/bin
	/opt/homebrew/sbin
	/usr/local/bin
	/usr/bin
	/bin
	/usr/sbin
	/sbin
	/Users/kaneshih/.fig/bin
	/Users/kaneshih/.local/bin
	/Users/kaneshih/Library/Android/sdk/tools
	/Users/kaneshih/Library/Android/sdk/platform-tools
	/Users/kaneshih/go/bin/
	/Users/kaneshih/Library/Android/sdk/tools
	/Users/kaneshih/Library/Android/sdk/platform-tools
	/Users/kaneshih/go/bin/
	/Users/kaneshih/Library/Android/sdk/tools
	/Users/kaneshih/Library/Android/sdk/platform-tools
	/Users/kaneshih/go/bin/
	/Users/kaneshih/Library/Android/sdk/tools
	/Users/kaneshih/Library/Android/sdk/platform-tools
	/Users/kaneshih/go/bin/

sys.path:
	/opt/homebrew/bin
	/opt/homebrew/Cellar/python@3.10/3.10.9/Frameworks/Python.framework/Versions/3.10/lib/python310.zip
	/opt/homebrew/Cellar/python@3.10/3.10.9/Frameworks/Python.framework/Versions/3.10/lib/python3.10
	/opt/homebrew/Cellar/python@3.10/3.10.9/Frameworks/Python.framework/Versions/3.10/lib/python3.10/lib-dynload
	/opt/homebrew/lib/python3.10/site-packages

sys.executable:
	/opt/homebrew/opt/python@3.10/bin/python3.10

sys.version:
	3.10.9 (main, Dec 15 2022, 10:44:50) [Clang 14.0.0 (clang-1400.0.29.202)]

platform.platform():
	macOS-12.6.3-arm64-arm-64bit

which -a jupyter:
	/opt/homebrew/bin/jupyter

pip list:
	Package                  Version
	------------------------ -----------
	anyio                    3.6.2
	appnope                  0.1.3
	argon2-cffi              21.3.0
	argon2-cffi-bindings     21.2.0
	arrow                    1.2.3
	asttokens                2.2.1
	attrs                    22.2.0
	Babel                    2.11.0
	backcall                 0.2.0
	beautifulsoup4           4.11.2
	bleach                   6.0.0
	certifi                  2022.12.7
	cffi                     1.15.1
	charset-normalizer       3.0.1
	comm                     0.1.2
	debugpy                  1.6.6
	decorator                5.1.1
	defusedxml               0.7.1
	executing                1.2.0
	fastjsonschema           2.16.2
	fqdn                     1.5.1
	idna                     3.4
	ipykernel                6.20.2
	ipython                  8.9.0
	ipython-genutils         0.2.0
	isoduration              20.11.0
	jedi                     0.18.2
	Jinja2                   3.1.2
	json5                    0.9.11
	jsonpointer              2.3
	jsonschema               4.17.3
	jupyter_client           8.0.2
	jupyter_core             5.2.0
	jupyter-events           0.6.3
	jupyter_server           2.2.0
	jupyter_server_terminals 0.4.4
	jupyterlab               3.5.3
	jupyterlab-pygments      0.2.2
	jupyterlab_server        2.19.0
	kotlin-jupyter-kernel    0.11.0.208
	MarkupSafe               2.1.2
	matplotlib-inline        0.1.6
	mistune                  2.0.4
	nbclassic                0.5.1
	nbclient                 0.7.2
	nbconvert                7.2.9
	nbformat                 5.7.3
	nest-asyncio             1.5.6
	notebook                 6.5.2
	notebook_shim            0.2.2
	packaging                23.0
	pandocfilters            1.5.0
	parso                    0.8.3
	pexpect                  4.8.0
	pickleshare              0.7.5
	pip                      23.0
	platformdirs             2.6.2
	prometheus-client        0.16.0
	prompt-toolkit           3.0.36
	psutil                   5.9.4
	ptyprocess               0.7.0
	pure-eval                0.2.2
	pycparser                2.21
	Pygments                 2.14.0
	pyrsistent               0.19.3
	python-dateutil          2.8.2
	python-json-logger       2.0.4
	pytz                     2022.7.1
	PyYAML                   6.0
	pyzmq                    25.0.0
	requests                 2.28.2
	rfc3339-validator        0.1.4
	rfc3986-validator        0.1.1
	Send2Trash               1.8.0
	setuptools               65.6.3
	six                      1.16.0
	sniffio                  1.3.0
	soupsieve                2.3.2.post1
	stack-data               0.6.2
	terminado                0.17.1
	tinycss2                 1.2.1
	tomli                    2.0.1
	tornado                  6.2
	traitlets                5.9.0
	uri-template             1.2.0
	urllib3                  1.26.14
	wcwidth                  0.2.6
	webcolors                1.12
	webencodings             0.5.1
	websocket-client         1.5.0
	wheel                    0.38.4
i

Ilya Muradyan

02/01/2023, 11:03 AM
It seems like you've built it from sources, right?
Try to execute %useLatestDescriptors, and then %use dataframe
k

Kane Shih

02/01/2023, 1:55 PM
oh wow! it works! You saved my day, thanks a lot 😃
24 Views