https://kotlinlang.org logo
#multiplatform
Title
# multiplatform
b

bnvinay92

02/02/2023, 3:54 PM
Hey, I have a KMP library (ios + jvm) (kotlin 1.7.20) that depends on another KMP library (also ios + jvm) that just upgraded to 1.6.21 from 1.6.10 and I started seeing this error when try to build with the updated library:
Copy code
Could not determine the dependencies of task ':my-module:compileKotlinMetadata'.
> Could not resolve all task dependencies for configuration ':my-module:metadataCompileClasspath'.
   > Could not resolve com.squareup.workflow1:workflow-runtime:1.8.0-beta11.
     Required by:
         project :my-module
      > The consumer was configured to find a usage of 'kotlin-api' of a library, preferably optimized for non-jvm, as well as attribute 'org.jetbrains.kotlin.platform.type' with value 'common'. However we cannot choose between the following variants of com.squareup.workflow1:workflow-runtime:1.8.0-beta11:
          - iosArm64ApiElements-published
          - iosSimulatorArm64ApiElements-published
          - iosX64ApiElements-published
          - jvmApiElements-published
          - jvmRuntimeElements-published
< and so on and so forth >
I've seen this before when the library happened to be shipping a ktlint artifact as well but not sure what could be causing this apart from the kotlin version change.
1
s

Sebastian Sellmair [JB]

02/02/2023, 4:08 PM
Which version of Kotlin is your project using? Please disable the compatibility variant and use 1.6.20 or higher
Your compile task is the legacy compilation, which is not needed anymore and not supported by many libraries
b

bnvinay92

02/02/2023, 4:12 PM
My project is using 1.7.20. But thanks, looks like removing the flag did the trick!
9 Views