https://kotlinlang.org logo
#compose-desktop
Title
# compose-desktop
d

darkmoon_uk

02/13/2023, 5:22 AM
This may have already been said; but is anyone in a position to reiterate clearly the position with Kotlin
1.8.20
and Compose (both Jetpack and Multiplatform)
? ⚠️ I saw in another thread that there would be no
1.8.20
compatible release for Compose
due to irreconcilable compatibility issues between K2 and the Compose compiler. alphabet yellow question If this is the case; when is the earliest a Kotlin
1.9.0
+ Compose Dev build
combination might become available?
k

Kirill Grouchnikov

02/13/2023, 5:49 AM
Wasn't that thread, and that particular reference, only for the K2 compiler?
d

darkmoon_uk

02/13/2023, 7:03 AM
That's why I'm looking for clarification - can we expect a
1.8.20
compatible Compose release, as long as we don't enable the K2 compiler with
-language-version 2.0
, or do the issues mentioned affect the whole release?
n

Nikita Lipsky

02/13/2023, 11:52 AM
The whole context of the thread you mention was about K2. There should be no problems with 1.8.20 and Compose unless you enable K2. BTW, I have just checked Kotlin 1.8.20-Beta with "visual-effects" Desktop sample and it works fine. Of course, we will test thoroughly Compose and compose compiler when we release 1.8.20 compatible Compose.
13 Views