what is the best (or just shorter) name for this `...
# naming
t
what is the best (or just shorter) name for this
fun Set<A>nonEmptyIntersection(other: Set<A>) = this.intersect(other).nonEmty()
?
l
intersects
?
t
I think looks too similar with
intersect
, but maybe
isIntersected
?
e
containsAny
?
t
containsAny
looks nice, but make me wonder is
hasAny
better?
okay, now I'm really think
sharedAny
should be use. with sharedAny I can do overload like:
set1.sharedAny(set2, set3, set4)
r
I've used
overlaps
for similar things in the past