https://kotlinlang.org logo
#intellij-plugins
Title
# intellij-plugins
r

robercoding

02/24/2023, 1:55 PM
Hey! Newbie getting into intellij plugins world 😄 I've made a copy-paste of this guide https://plugins.jetbrains.com/docs/intellij/settings-tutorial.html to make sure I have some base to start working, adding and understanding. (I've already worked with actions and went great!) Sadly when working with "_Settings tutorial_" I'm getting an error. The component under "Tools" section keeps loading forever and coming back to intellij run terminal, it shows an error - (Check 🧵 ) I've already tried to create a fresh project again to see if I missed anything but still throwing me the same issue
Error:
Copy code
Caused by: java.lang.ClassNotFoundException: com.robercoding.demo.appsettings.AppSettingsConfigurable PluginClassLoader(plugin=PluginDescriptor(name=Demo, id=com.robercoding.demo, descriptorPath=plugin.xml, path=~/IdeaProjects/demo/build/idea-sandbox/plugins/demo, version=1.0-SNAPSHOT, package=null, isBundled=false), packagePrefix=null, instanceId=18, state=active)
Image that keeps loading forever:
Does anyone know if I could be missing any obvious step? 🤔 Or if it's a common issue?
I was working under kotlin directory 🤦‍♂️
Using Kotlin code under kotlin directory works bloodtrail
18 Views