https://kotlinlang.org logo
#intellij
Title
# intellij
j

Jonas

12/04/2023, 2:47 PM
👋 Anyone knows how to disable the auto-folding of these string references in Android Studio? It’s really annoying to always see just “…”. I tried to disable Editor > General > Code Folding > Fold by default > Android > String references Without any luck. Is there maybe an Annotation or comment to disable it for a file?
t

twisterrob

12/08/2023, 2:05 AM
Can't solve it blindly, but a few things I can think of: • when changing the folding settings, it will not change open files, so you need to re-open file (works for me)/restart IDE (surely works) • folding regions might be remembered per file, so it only takes effect on unopened files? try manually expanding and re-open/restarting • I remember seeing "..." previews in the context of this bug, see repro code comments in `#1`/screenshots in
#2
. Try to upgrade to latest AS (Hedgehog) + AGP 8.2 in build.gradle files. (I see previews in HH + AGP 8.1.x, see attached, and toggling the setting works after re-opening the file.) If neither of these work, report a new bug at https://issuetracker.google.com/
j

Jonas

12/12/2023, 6:25 AM
Thanks for the recommendations! • I tried reopening the files before. Haven’t tried a restart yet. • Also considered if they get remembered and tried exactly that. • I’ll have a look at the bug later and might try the latest stable AS version (currently on Iguana | 2023.2.1 Canary 16). Already use AGP 8.1.x.
2 Views