Has anyone tried to publish a library targeting us...
# compose-web
Has anyone tried to publish a library targeting using just
as a dependency? I’m trying to make a library with a “common Compose” module that’s compose-runtime only, and then additional modules that add on support for Material and JS DOM, but it seems like there’s a problem with compose runtime being used in the common sourceSet
Build logs look like the compose runtime artifact is missing module metatdata for the common variant (currently using the latest build, dev755) https://github.com/copper-leaf/kotlin-json-forms/runs/7921533761?check_suite_focus=true#step:5:537
Missing metadata might also explain why everything in that module shows as red in IntelliJ. But the individual targets are still able to compile and run
Hm, I use dev745 because of kotlin 1.7.10, but I don't have this problem: https://github.com/hfhbd/routing-compose/blob/c7a4e08ead5db9162b1076654171e52fb78609de/build.gradle.kts#L45
I was initially on 1.7.10 and dev745, but was seeing the problem there too. Strangely it seemed like the later build reverted back to 1.7.0. But I see several things in your build file that aren’t in mine, maybe one of those will work. Thanks!
Try to remove
Copy code
Some settings are now true by default, but it still results into broken builds if you set them now manually
I think it was those gradle.properties flags causing the problem, I got the build to pass locally once I removed them. Thanks for the help!