LeoColman
04/16/2019, 3:59 PMChar.isDigit
to not have it's opposite Char.isNotDigit
?Alan Donizete
04/16/2019, 4:00 PMLeoColman
04/16/2019, 4:05 PMLeoColman
04/16/2019, 4:05 PMString.isEmpty
, but we have a String.isNotEmpty
LeoColman
04/16/2019, 4:05 PMlouiscad
04/16/2019, 4:18 PMStephan Schroeder
04/17/2019, 10:08 AMlistOfStrings.filter(String::isNotEmpty)
is slightly more readable than listOfStrings.filter {!it.isEmpty()}
) but also pollutes the API a little bit (double functions). So I guess you'd create one of those is it is used "often".