Ok this one is really killing me now: `Could not r...
# ktor
Ok this one is really killing me now:
Could not resolve io.ktor:ktor-client-js:1.6.0
error every time at Gradle sync. But... • The project does build and run • The artifact name is correct • I've added
repo directly to the using project • The artifact is there • All other Ktor artifacts are resolving just fine. • I've cleared
folders I am using
target, in case this has to do with resolving IR variant(?) ...nearly at a loss. Is anyone else seeing weird stuck artifact mis-resolution around Ktor?
I'm using Android Studio, but got the same result from IntelliJ after I stripped out the Android stuff.
So far looks like a bug in:
Which version of gradle are you using?
@Dominaezzz 7.0.2
I just trimmed down to this reproduction project ☝️
Might be able to trim further but this seemed like a reasonable place to stop.
Ah, I reckon that version might be too high. This might be a #multiplatform issue.
I am prepared to raise a YouTrack, but if anyone cares to try and Gradle sync this project in IDE and just confirm the error, I'd have added confidence that I'm not wasting JB's time.
My result is that
./gradlew assemble
succeeds but Gradle Sync in IDE does not.
@Dominaezzz Thanks I'll try that variable...
Noted current KMP samples are using Gradle 6.5
Same error w/ Gradle 6.5 🙅
@dsavvinov @h0tk3y
🙏 1
Thanks for the minifying and reporting the issue! We’ve taken a look at it, and apparently when we were adding Gradle attributes for IR/Legacy JS targets, we’ve missed a few configurations. They are used exclusively by IDE Sync, that’s why the build finishes successfully, but sync fails. The fix should arrive in 1.5.30 (maaaaaaybe in 1.5.20, but that’s highly unlikely)