https://kotlinlang.org logo
#ktor
Title
# ktor
m

mantono

08/08/2019, 6:43 AM
I am bit confused. Version 1.2.3 of Ktor has breaking changes (as stated in the release notes) and it did indeed break my code - does Ktor not use semantic versioning or is there something I haven't grasped? (also I don't get it to compile even if I use Kotlin 1.3.41).
h

hallvard

08/08/2019, 9:08 AM
Well, even on the front page of ktor.io, the little
build
badge just above the footer states that the builds fail, so maybe this is meant to be ... 🙂
m

mantono

08/09/2019, 3:16 PM
It turns out I forgot to change the version of the kotlin plugin, I had only changed the version of kotlin-std lib to 1.3.41
f

Frank Harper

08/10/2019, 3:13 PM
I'm just getting started with Ktor, and am running in to a similar issue with the requirement for Kotlin 1.3.41 To launch my app, I run
../gradlew appengineRun
, and I get this error message:
Copy code
'receive(): T' is only available since Kotlin 1.3.40 and cannot be used in Kotlin 1.3. This function requires Kotlin 1.3.40+
I have triple checked my build.gradle, and it appears that I am using Kotlin 1.3.41, so the error message is very confusing 😦.
my build.gradle
When I change
ext.ktor_version
to 1.2.0 the error goes away. Any ideas?
m

mantono

08/12/2019, 6:14 AM
I had the same problem. Do you use 1.3.41 for both the compiler plugin and kotlin-stdlib-jdk8? In my case I had missed the plugin version.
5 Views