Hello :wave: Not a Kotlin plugin related issue (at...
# intellij
Hello 👋 Not a Kotlin plugin related issue (at least I don't think so) but I'm hitting some weird problem with Intellij that if I switch from openJDK 15 to openJDK 11 (tried one installed by Intellij and one from sdkman) it starts complaining that it no longer can resolve
etc, any ideas?
Although that was between JDK 8 and 11 now that I think about it. But looks really similar.
yeah it does look very similar
Gradle works fine with installed JDK 11 so unit tests also work.... its just source files are marked as with issues
Does it help to set File | Settings | Build, Execution, Deployment | Build Tools | Gradle | Gradle JVM to Project SDK and reimport the project? Does it help to remove (rename) config and system [IDEA directories](https://www.jetbrains.com/help/idea/tuning-the-ide.html#config-directory), remove cache from
, remove .idea project directory and reimport the project?
Tried removing .idea and .gradle directories and reimporting the project but that didnt work. I'll try the above
wiped out system IDEA directories, system
directory, project
directories -> it imported a project using system setting of Gradle + JDK 11 but the classes still complain about the same updating the project to JDK 15 fixes the IDEA issues 😢 since I'm using Gradle for build/tests in IDEA they are run using JDK 11 with the warning that project setting is set to 15 but we are using 11.... really have no idea what else might be happening here