:white_check_mark: [RESOLVED] Thread: AS can't com...
# android
t
Ôťů [RESOLVED] Thread: AS can't compile with
dagger.hilt.android.plugin
plugin ­čžÁ
Copy code
// build.gradle
classpath 'com.google.dagger:hilt-android-gradle-plugin:2.35.1'

// app/build.gradle
apply plugin: 'kotlin-kapt'
apply plugin: 'dagger.hilt.android.plugin'
and then am getting
Copy code
Unable to find method ''void com.android.build.api.extension.AndroidComponentsExtension$DefaultImpls.androidTests$default(com.android.build.api.extension.AndroidComponentsExtension, com.android.build.api.extension.VariantSelector, kotlin.jvm.functions.Function1, int, java.lang.Object)''
'void com.android.build.api.extension.AndroidComponentsExtension$DefaultImpls.androidTests$default(com.android.build.api.extension.AndroidComponentsExtension, com.android.build.api.extension.VariantSelector, kotlin.jvm.functions.Function1, int, java.lang.Object)'
My AS Version
Copy code
Android Studio Arctic Fox | 2020.3.1 Beta 3
Build #AI-203.7717.56.2031.7395685, built on May 25, 2021
Runtime version: 11.0.10+0-b96-7249189 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Linux 4.15.0-142-generic
GC: G1 Young Generation, G1 Old Generation
Memory: 2048M
Cores: 6
Registry: external.system.auto.import.disabled=true
Non-Bundled Plugins: Key Promoter X, com.wakatime.intellij.plugin, wu.seal.tool.jsontokotlin, org.jetbrains.kotlin, cn.wjdghd.unique.plugin.id, com.github.developerutils.kotlin-function-arguments-helper, org.intellij.plugins.markdown
Current Desktop: Unity
Updating hilt to 2.36 fixed it. Thanks to @Shakil Karim