https://kotlinlang.org logo
#android
Title
# android
s

Shan

03/28/2019, 6:30 PM
Does anyone know when the Android Gradle plugin will let me upgrade to Gradle 5.3.1? Keep getting this error when I try to sync after upgrading
Gradle sync failed: Unsupported method: IdeaModuleDependency.getDependencyModule()
. Am I doing something wrong here? It seems like other people are using Gradle v5.0+ .. 🤔
I am stuck on Gradle version 4.10.2 at the moment with this bug 😞
a

Adam Kirk

03/28/2019, 6:39 PM
I am able to use 5.3.1 with Android Studio 3.3.2. Try creating a new project and see if that one will update. in File->Project Structure->Project->Gradle
s

Shan

03/28/2019, 6:54 PM
Nada, still the same bug
r

rook

03/28/2019, 7:18 PM
I’m currently using
5.0-all
in all my projects without issue
l

luke

03/28/2019, 7:22 PM
@Shan are you using Android Studio, or IDEA?
s

Shan

03/28/2019, 7:22 PM
@luke Using Intellij 2018.3.5
l

luke

03/28/2019, 7:22 PM
Upgrade to 2019.01, just came out yesterday (or day before?)... seems to address this
👍 1
s

Shan

03/28/2019, 7:38 PM
That fixed it! 🎉 Thank you! Didn't realise there was a new version.
👍 4
2 Views