Thread
#exposed
    Sergio Casero

    Sergio Casero

    3 years ago
    Hi guys! one question, I'm trying to connect exposed with my database on Google Cloud, I can do that "without any problems". But seems to be too slow, Could the issue be that I'm not using SSL? I get this warning every time I perform a query:
    WARN: Establishing SSL connection without server's identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn't set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to 'false'. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification.
    tapac

    tapac

    3 years ago
    Do you connect your local app to database deployed to G.Cloud? If so, then please measure latency and bandwidth to a cloud.
    Sergio Casero

    Sergio Casero

    3 years ago
    The problem was that I was opening a connection per query
    Now I'm using HikariCP