Hi there, I am just getting my lib ready for the c...
# coroutines
l
Hi there, I am just getting my lib ready for the coming of 1.3 (I am using 1.3.0-rc-57), and just a little naming note - when I look into the Dispatchers object, there is Default and Unconfined. I wouldn't mind going lowercase here, since it's just a field, right? (not a subclass etc.) I remember I already proposed going with lowercased
io {}
pool as well (in some github discussions), so I am just re-throwing this idea again before the release decisions will be final (if they're not already) 🙂 .
+ there's a typo in the javadoc (double "to")
Copy code
with [<http://Dispatchers.IO|Dispatchers.IO>] and thus can switch to
     * to context without performing an actual thread context switch.
e
Even though it is technically a variable, it is conceptually an object.
(also
default
is a keyword in Java, so if we give such a name in Kotlin, we’ll have to use a different name to make it visible from Java)
(thanks for typo correction)
l
Ah, I see 🙂 . Although the idea of somebody trying to call a coroutine from Java seems weird to me, but let there be the possibility 😄 .
e
Calling - no, but there are real use-cases were you might be configuring your application via Java-based DI framework, and injecting your dispatchers is the major thing you’ll be doing.
👍 1
1