Hi, on a fresh kotest master (commit 61c450) I'm h...
# kotest-contributors
a
Hi, on a fresh kotest master (commit 61c450) I'm having trouble running gradle commands. In particular, this is my error:
Copy code
$ ./gradlew test

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring project ':buildSrc'.
> Could not resolve all artifacts for configuration ':buildSrc:classpath'.
   > Could not resolve org.gradle.kotlin:plugins:1.3.6.
     Required by:
         project :buildSrc > org.gradle.kotlin.kotlin-dsl:org.gradle.kotlin.kotlin-dsl.gradle.plugin:1.3.6
      > Could not resolve org.gradle.kotlin:plugins:1.3.6.
         > Could not get resource '<https://plugins.gradle.org/m2/org/gradle/kotlin/plugins/1.3.6/plugins-1.3.6.module>'.
            > Could not GET '<https://repo.jfrog.org/artifactory/libs-release-bintray/org/gradle/kotlin/plugins/1.3.6/plugins-1.3.6.module?referrer>'.
               > sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at <https://help.gradle.org>

Deprecated Gradle features were used in this build, making it incompatible with Gradle 7.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See <https://docs.gradle.org/6.5.1/userguide/command_line_interface.html#sec:command_line_warnings>

BUILD FAILED in 2s
When I open up https://plugins.gradle.org/m2/org/gradle/kotlin/plugins/1.3.6/plugins-1.3.6.module in a web browser I get a JSON response with status 404. Has anyone seen this before or does anyone have any ideas for things to try? I have tried removing both my local and global gradle caches but I still get the error.
s
Just seems like internet issues? Or behind a firewall or something
­čĹŹ 1