<@U2E974ELT> I think you'll like that change. :poi...
# kotlin-roadmap
l
@elizarov I think you'll like that change. ☝️ Also, I believe the name
primitive class
is less confusing for value types, and
inline class
makes more sense for Kotlin's usage.
5
e
Not really. We though that we could rename Kotlin inline classes to "JVM Primitive" classes, since that would exactly explain what Kotlin inline classes are about -- they are compiled into the corresponding JVM primitives. Now the "primitive class" in JVM is extremely confusing name choice, since they are not primitive -- they can be complex, composite entities. The only upside for us here is that we can now continue using the word "inline", maybe.
l
But
inline
wasn't a good name for type values either, do you agree? Shouldn't value types be called `struct`s as in C, C++ and Swift? I think that is more self-explanatory to what it is. Regarding Kotlin inline classes, I think the
inline
keyword is alright, I read it like "usages of this class will be inlined whenever possible to the wrapped type". A
@JvmPrimitive
annotation would limit it to the JVM while it can work in JS and possibly other targets. Maybe you have something different in mind though?
e
It is really not simple. I am not surprised that Java struggles for a good name so long, too