# multiplatform

Neal Sanche

02/18/2021, 9:20 PM
Today I ran into an issue with the
target on a project where the test (only one test, as a proof of concept) previously passed. After adding a second KMP module (to work around a conflict between two gradle plugins), the ios tests now hang indefinitely with what looks like a gradle daemon connection issue. Thing is, the second module doesn't contain any tests, it is just code generation. Now the tests just repeat the following over and over:
Copy code
2021-02-18T14:17:06.271-0700 [DEBUG] [org.gradle.cache.internal.DefaultFileLockManager] Waiting to acquire shared lock on daemon addresses registry.
2021-02-18T14:17:06.271-0700 [DEBUG] [org.gradle.cache.internal.DefaultFileLockManager] Lock acquired on daemon addresses registry.
2021-02-18T14:17:06.271-0700 [DEBUG] [org.gradle.cache.internal.DefaultFileLockManager] Releasing lock on daemon addresses registry.
The way that I included the second KMP module was using a dependency entry:
Copy code
I'm not sure what I should try to get the tests to finish as expected. Any ideas?
I figured this out. Something about the moko-network runtime classes were causing the coroutines support to be messed up, leading to the
target to hang. Removing that library solved the issue for me.